Bienvenu dans notre communauté !

Soit le bienvenu sur notre forum d'entre-aide mécanique spécialisé dans les véhicules du groupe VW. N'hésite pas à t'inscrire pour bénéficier d'un accès libre et sans limites à la base de connaissance que représente ce forum, ainsi qu'au savoir et conseils de ses membres. Nous voulons notre communauté simple et sans fioritures. À bientôt.

S'incrire maintenant

Publicité

Les membres ne voient pas cette publicité.

slinouille

Administrateur
Membre du Staff
Inscrit
18/11/19
messages
378
Localisation
Le Crès, France
Marque
VW
Modèle
Golf
Date
13/11/12
Cylindrée
2
Km
180000
Type
Diesel
Code moteur
CRBC
Code boite
PFL
Code pont
6S
VIN
WVWZZZAUZDP015309
VCDS
VCDS

Publicité

Les membres ne voient pas cette publicité.
Salut,

Ce fil me sert de suivi et sera mis à jour au fur et à mesure, si vous avez des commentaires, n'hésitez pas ;)

Depuis plusieurs mois, je récupère des informations et autres matériel nécessaire à la réalisation du rétrofit de la caméra frontale sur une Golf 7.
Ce rétrofit est sensé pouvoir ajouter plusieurs fonctions à la voiture tels que le lane assist, sign assist, dynamic light assist (si on a les feux directionnels), etc.
Vous devez être enregistré pour pouvoir accèder à cette image


J'ai vu que plusieurs personnes changent leur parebrise pour pouvoir prendre celui qui inclue une zone "blanche" pour la caméra.

Ça me paraissait bien trop contraignant et j'ai cherché une autre solution.
Pour finalement trouver l'astuce d'insérer la caméra dans l'excroissance du rétroviseur.
L'installation consistera donc à installer l'objectif de la caméra au niveau du rétroviseur et de fixer le boitier caméra dans le ciel de toit.
Pour cela, il faut changer le rétroviseur pour un permettant l'installation de l'objectif de la caméra, et relier l'objectif et le boitier avec une extension de nappe.

Matériel​


Au fil du temps et des opportunités sur internet, j'ai récupéré :

  • un rétroviseur (3G0857511AG UOG) sur LBC
  • un cache caméra (3G0858548A 9B9) sur Ebay
  • une caméra (5Q0980653F) sur Ebay
  • une nappe 24 pistes et son extension F/F (sur Aliexpress)
  • un faisceau permettant de relier la caméra à la voiture (sur Aliexpress)

Schémas électriques​

Concernant le raccordement électrique, j'ai les schémas de la voiture
Pour la partie Caméra


Pour la partie Régulateur de distance (ACC)


Connexion de câblage​

Voici le tableau de connecteur à coté du repose pied.



Schéma de branchement :
  • Pin 1 - CAN-L de l'ACC (sur le connecteur JAUNE pin 11)
  • Pin 2 - CAN-L du TIUL
Note de branchement : Très compliqué mais sur la Golf7 il y a possibilité de repiquer directement sur le connecteur noir.
Au niveau du connecteur J533, on va venir souder sur fil 13 (Orange et marron)

  • Pin 4 - Dégivreur de capteur avant (non utilisé dans mon cas)
  • Pin 5 - Masse (GND au niveau du tapis de sol en bas à gauche)
  • Pin 6 - Fusible + (7.5A) (fusible 32 du porte fusibles)
  • Pin 7 - CAN-H de l'ACC (sur le connecteur JAUNE pin 9)
Idem PIN1
  • Pin 8 - CAN-H du TIUL
Note : Au niveau du connecteur J533, on venir souder sur fil 12 (Orange et gris)
Idem PIN2


Basically, what you're going to do is pull the two wires that you're pointing to (the Orange/Grey and Orange/Brown wires that are plugged into the 17-pin black connector) and plug those into the "female" ports of the small black connector you're holding in your hand. That black connector is effectively a splitter - takes one wire coming in and splits it two ways: The short ends on the other end of your two-port black connector simply go back into the ports on the 17-pin black connector; the long ends (that big roll of OR/BR and OR/GR CAN twisted wire) go to the ACC camera.

Now, having said all that, I ran into an issue where my metal terminal ends did not fit into the connector - maybe you'll have better luck than I did. After trying numerous times, I ended up cutting the wires and using heat-shrink butt connectors to change the terminal ends from one to the other..



Concernant le branchement sur le CAN extended H & L des pins 2 & 8​

Pour se repiquer sur le connecteur J533 (Interface de diag)

Fixation de la caméra​


Calibration de la caméra​

Pour la caméra, une fois installée, il faudra la calibrer. Pour cela, il faudra imprimer une affiche spéciale contenant la mire de calibration.
Elle porte le code VAS6430 (à télécharger en pièce jointe).


Je pense le faire imprimer sur internet (une 20aine d'€)

Le protocole de calibration :
  • Horizontalement : l'affiche de calibration doit être placée à 150cm +/- 2cm depuis le milieu des roues. Il faut par ailleurs qu'elle soit parfaitement allignée par rapport aux 2 roues.
  • Verticalement : le centre du rectangle blanc contenant les 2 points noirs doit être à la meme hauteur que l'objectif de la caméra (approximativement 120-125cm du sol en fonction des suspensions et des roues)
Avec VCDS
You must have your car's model software on your A5 camera (for values calcul).
Enter good values for wheel edge housing on Adaptations with security access.
Control camera height calculated by controller with real value.
Adjust values if needed to obtain the good camera height.
Then:
Basic settings -> search target (to recognize it) -> initial online calibration (to calculate camera's angles, which will change as you drive and the car moves) -> static calibration... finished
It took about two minutes... after a couple of days scratching head.

Then you drive on straight's roads and dynamic calibration will be done correctly. Straighter the road is, quicker the calibration will be.

No need to run EAL calibration, it's done for blank cameras.

Documentation​

Principale source d'inspiration :
Activation avec VCDS :

Vidéo Youtube en 3 parties :
xc_hide_links_from_guests_guests_error_hide_media

xc_hide_links_from_guests_guests_error_hide_media

xc_hide_links_from_guests_guests_error_hide_media


Pour enlever la garniture à coté du repose pied :
xc_hide_links_from_guests_guests_error_hide_media

Support de caméra :

Questions ouvertes​

Points qu'il me reste à résoudre pour pouvoir me lancer.

Q1 : les tutoriels trouvés montrent l'utilisation de ODIS que je n'ai pas. Mais j'ai VCDS. Du coup, est-il possible de faire toute la manipulation avec VCDS ? Et si oui, quelle est-elle ?

Q2 : Je possède l'ACC. Suis-je obligé de cabler comme indiqué ou est-ce cablé d'origine ?

Q3 : Ou brancher les pins 1, 2, 7 et 8 (pas compris précisément) ?




Notes non triées :
The 4 data cables goes as

camera pin 1 >> To CanBus 2 Brown Plug pin 11
camera pin 7 >> To CanBus 2 Brown Plug pin 9
(there is no adaptive cruise control for me so i stop there)

camera pin 2 >> To CanBus 1 CAN-LOW
camera pin 8 >> To CanBus 1 CAN HIGH

So for pins 2 and 8 , the Cangateway Red plug is no Go for me ,
So i just need to find the
CAN-LOW
CAN-HIGH
Either to the "black plug" of the previous picture ..
Or i saw that my META System Alarm is using Can H- Can L


Traffic sign Assist:

Controller 5F (Information Electrical)
10 - Adaptations
Select channel: (63) Car_Function_List_BAP_Gen2-traffic_sign_recognition_0x21
Adjust Value to activated

Channel: (151) Car_Function_Adaptations_Gen2-menu_menu_display_road_sign_identification
Adjust Value to activated

Controller A5 (Front / front view camera)
07 - Coding
Byte 1
Bit 0 Enable - "01 traffic sign recognition (FTE) active"

Controller 17 (Instruments)
07 Coding
Byte 5
Bit 2 Enable - "Traffic Sign Recognition installed"

Controller 5F (Information Electr.)
07 - Coding
Byte 24 Bit 6 - tick Traffic Sign Display (VZA) active

Controller A5 (Front / front view camera)
07 - Coding
Byte 16
Bit 4 - tick this box (currently there are no descriptions for A5 longcoding)


Lane Assist: (Not in english but the settings are)

STG 17 (Schalttafel) auswählen
STG Lange Codierung -> Funktion 07
Bye 4
Bit 6 Spurhalteassistent/Lane Assist Active

Bye 11
Bit 1 Spurhalteassistent/Lane Assist Information BAP verbaut Active

STG A5 (Front-/Vorfeldkamera) auswählen
STG Lange Codierung -> Funktion 07
Byte 0
Bit 0 Spurhalteassistent HCA verbaut Active

STG A5 (Front-/Vorfeldkamera) auswählen
Security Access 20103 eingeben
Adaptation
Kanal - HCA_On_State auswählen
Setting via Menu

Kanal - HCA_Warning_intensity auswählen
Setting via Menu

Kanal - BAP_Personalisierung auswählen
Wert auf nicht aktiviert setzen

Kanal - Eingriffszeitpunkt auswählen
Late Setting via menu

Kanal - Personalisierung Spurthalteassistent bei Kl.15 ein auswählen
Last setting

STG 44 (Lenkhilfe) auswählen
Zugriffscode 19249 eingeben
STG Lange Codierung -> Funktion 07
Bye 0
Bit 4 Spurhalteassistent HCA verbaut aktivieren


STG 5F (Informationselektronik) auswählen
STG Anpassung -> Funktion 10
Kanal - (49)-Fahrzeug Funktionsliste BAP-LDW_HCA_0x19 auswählen
Wert auf Aktiviert setzen

Kanal - (21)-Fahrzeug Menü Bedienung-menu_display_Lane_Departure_Warning auswählen
Wert auf Aktiviert setzen

Kanal - (23)-Fahrzeug Menü Bedienung_menu_display_Lane_Departure_Warning_over_threshold_high auswählen
Wert auf Aktiviert setzen


High Beam Assist

09 Cental Electrics
Security access 31347
Adapation
Assistance light functions Menuesteuerung Fernlichtassistent
Change to Present (Enables setting on menu)

Then go to long coding of 09 Central Electrics
Byte 2 Bit 0 to 1
The byte should change from 0A to 0B for 6mt, Or 1A to 1B on DSG (I Had to mess a bit with these settings as I Have Bi xenon Replicas)

A5
Long coding
For 5Q0980653G Set byte 2 to 01 light assist AFS: High beam assist

For 3Q0980654G
Set byte 21 to 20 light assist AFS: High beam assist

Then go to car - setup - light - And enable light assist.

Set your light switch to Auto and flick the lever just as you would turn high beams on and it will show the HBA Icon on the dash.

... à continuer
 

Pièces jointes

  • VAS6430 Lane Assist Board.pdf
    302.4 KB · Affichages: 23
Dernière édition:
salut,

Alors j'ai pu enfin avancer.
J'ai tout installé, cablé et paramétré.
Maintenant j'essaye de calibrer ce fichu module mais impossible.
Je me heurte à un message "Request Sequence Error" lors que je lance la procédure de calibration statique de la caméra.
Si je fais une recherche de la mire de calibrage, j'obtiens un message comme quoi c'est ok.

Je me suis dit que ce message était synonyme d'une procédure non respectée, du coup j'ai recherché et je suis tombé sur un post disant qu'il fallait que :
  1. le contact soit mis sans le moteur tournant
  2. les portes soient fermées
  3. les feux éteints
Chose que j'ai faite mais pareil.

Peut-etre avez-vous des infos ?

EDIT : Pour infos, j'ai codé les différents modules avec VCDS avant de faire la calibration. Est-ce que cela pourrait avoir un impact sur le fait d'avoir ce message ?

EDIT 2 : Voici les erreurs que j'ai sur le module

A5-Frt Sens. Drv. Assist -- Status: Not registered 0011

Puis en détail :

-------------------------------------------------------------------------------
Address A5: Frt Sens. Drv. Assist (R242) Labels:| 5Q0-980-653.clb
Part No SW: 5Q0 980 653 F HW: 5Q0 980 653
Component: MQB_MFK H06 0052
Serial number: 00000226977
Coding: 0101010001020303000000010100000100
Shop #: WSC 06385 790 00016
ASAM Dataset: EV_MFKBoschAU370 001001
ROD: EV_MFKBoschAU370.rod
VCID: 3B2335C5A3EAB35FDC5-806E

3 Faults Found:
2555904 - Databus
U1121 00 [009] - Missing Message
[PSD_01_TO_FAILURE]
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 6
Fault Frequency: 24
Reset counter: 32
Mileage: 168361 km
Date: 2020.12.20
Time: 15:59:01

Control Module temperature: 36 °C
Outside air temperature: 12.0 °C
Vehicle speed: 0.00 km/h
Voltage terminal 15: 12.1 V
Terminal 15 on: 357.6 s

1114112 - Databus
U1121 00 [009] - Missing Message
[SWA_01_TO_FAILURE]
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 6
Fault Frequency: 27
Reset counter: 32
Mileage: 168361 km
Date: 2020.12.20
Time: 15:59:00

Control Module temperature: 36 °C
Outside air temperature: 12.0 °C
Vehicle speed: 0.00 km/h
Voltage terminal 15: 12.1 V
Terminal 15 on: 356.6 s

0768 - No Basic Setting
B2010 00 [009] - -
[suCalibVinMismatchFailure]
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 3
Fault Frequency: 20
Reset counter: 32

Control Module temperature: ERROR
Outside air temperature: 12.0 °C
Vehicle speed: 0.00 km/h
Voltage terminal 15: 11.4 V
Terminal 15 on: 0.6 s

A priori le dernier message existe dès lors que la caméra n'est pas calibrée.

Merci
 
Dernière édition:

Publicité

1114112 - Databus
U1121 00 [009] - Missing Message
[SWA_01_TO_FAILURE]
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 6
Fault Frequency: 27
Reset counter: 32
Mileage: 168361 km
Date: 2020.12.20
Time: 15:59:00

Cette erreur est du à l'absence de communication avec un autre module...

Le problème étant de savoir avec quel autre module le « A5-Frt Sens. Drv. Assist » cherche à communiquer...
 
Tu as suivi un tutoriel pour ton retrofit ?

Il n'y avait pas un recodage dans un autre module (le 44) ?
 
Ou peut-être une option codée en trop ?

- « ».
 
Merci de ton retour
Alors j'ai suivi les instructions de codage qui sont à la fin du message initial de ce fil 😉
Je pense aussi à un codage supplémentaire mais je n'ai rien fait autre que de suivre ce process
 
Merci de ton retour
Alors j'ai suivi les instructions de codage qui sont à la fin du message initial de ce fil 😉
Je pense aussi à un codage supplémentaire mais je n'ai rien fait autre que de suivre ce process

Dans le lien en allemand, le problème était du à des codages d'options en trop, ce qui faisait que le calculateur A5 cherchait à communiquer avec d'autres calculateurs codés en option mais non présents...
 
Par contre il y a un truc que je trouve curieux.
Si on regarde la date de l'erreur dans le log vcds, on peut voir le 20/12.
Or j'ai fait un clear codes tout a l'heure et l'erreur est revenue avec cet horodatage alors qu'on est le 29/12.
Cest pas curieux ? 🤔
 
Dernière édition:
salut ,

Je ne pense pas que la calibration soit si simple que ça à réaliser

xc_hide_links_from_guests_guests_error_hide_media

@+
 
Peut-tu faire un « Autoscan » avec « VCDS » :

Normalement, voici comment je pratique de mon côté lors d'un autoscan, dans l'ordre :

- Je recharge ma batterie (bien souvent la veille).
- Le jour « J », je lance un autoscan , à la fin de l'autoscan je fais « Sauver ».
- Une fois que l'autoscan a été sauvé, j'efface tous les défauts, cela a pour effet d'effacer tous les défauts qui étaient présents et de relancer dans la foulée un autoscan.
- Une fois le deuxième autoscan terminé, je fais encore « sauver », enfin je peux quitter le menu autoscan .
- Dans le répertoire d'installation de mon câble je récupère la log de mon autoscan, que je poste au complet (1er scan et 2eme scan sont normalement à la suite).


PS : Poste le fichier texte, pas un copier-coller...
 
Toujours sur le forum en allemand :

- « ».

Ça parle de version de firmware, de version de MIB, enfin bref, en fonction de ta version de MIB, il faut choisir des réglages appropriés...
 
******, ça a l'air sioux à configurer, les paramètres sont croisés en fonction de 3 tonnes de conditions (version de firmware, de MIB, etc...) et pas un tableau récapitulatif pour montrer les codages en fonctions de ces conditions... :( :( :(
 
Salut,
Alors j'ai fait un peu le ménage dans mes différents codages.
J'ai donc tout désactivé pour revenir à une situation de configuration "pré-installation".
J'avais donc des erreurs qui apparaissaient du style "Additional Installations Detected", chose qui semble somme toute assez normal.

A ce moment là et sans le "lane assist" de codé, j'avais comme erreur au niveau du module A5 la suivante
Code:
Address A5: Frt Sens. Drv. Assist (R242)       Labels:* None
   Part No SW: 5Q0 980 653 F    HW: 5Q0 980 653
   Component: MQB_MFK       H06 0052 
   Serial number: 00000226977   
   Coding: 0001000001020303000000000100000100
   Shop #: WSC 06385 790 00016
   ASAM Dataset: EV_MFKBoschAU370 001001
   ROD: EV_MFKBoschAU370.rod
   VCID: 3B2337F113E65E03661-806E

1 Fault Found
2555904 - Databus
          U1121 00 [009] - Missing Message
          [PSD_01_TO_FAILURE]
          Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 6
                    Fault Frequency: 1
                    Reset counter: 39
                    Mileage: 168720 km
                    Date: 2021.01.09
                    Time: 12:13:30

                    Control Module temperature: 19 °C
                    Outside temperature: 6.0 °C
                    Vehicle speed: 0.00 km/h
                    Voltage terminal 15: 12.4 V
                    Terminal 15 on: 100.2 s

En tentant une calibration statique, j'avais à nouveau cette erreur "Request sequence error".
Je me suis donc dit qu'il faudrait que je recode proprement la partie "Lane assist".
Dès lors le lecture des défauts me remonte l'erreur
Code:
Address A5: Frt Sens. Drv. Assist       Labels: 5Q0-980-653.clb
Control Module Part Number: 5Q0 980 653 F    HW: 5Q0 980 653
  Component and/or Version: MQB_MFK       H06 0052
           Software Coding: 0000000001020303000000000100000100
            Work Shop Code: WSC 06385 790 00016
              ASAM Dataset: EV_MFKBoschAU370 001001 (VW37)
                       ROD: EV_MFKBoschAU370.rod
                      VCID: 3B2337F113E65E03661-806E
1 Fault Found

0660 - No Basic Setting
          B2010 00 [009] - -
          [ruCalibMissingFailure]
          Confirmed - Tested Since Memory Clear
             Freeze Frame
                    Fault Status: 00000001
                    Fault Priority: 3
                    Fault Frequency: 1
                    Reset counter: 39
                    Mileage: 168720 km
                    Date: 2021.01.09
                    Time: 15:18:09

                    Control Module temperature: 25 °C
                    Outside temperature: 7.0 °C
                    Vehicle speed: 0.00 km/h
                    Voltage terminal 15: 12.3 V
                    Terminal 15 on: 279.0 s

Erreur qui semble somme toute normale puisque la caméra n'est pas calibrée.

Mais quand je relance une calibration statique, j'ai à nouveau cette erreur "Request sequence error".

Et du coup j'ai l'affreux sentiment de tourner en rond :rolleyes:

Voyez vous autre chose que je pourrais tenter ?
 
Tu as du déjà voir ce sujet : « ».
 
Merci.

Non je ne l'avais pas vu précédemment.

Par contre je ne vois pas ce qu'apporte VCP par rapport à VCDS.
Pour faire ces mise à jour de firmware, il est bien nécessaire d'avoir les fichiers de mise à jour.
Mais ou les trouve-t-on ?
Ils seraient intégrés à VCP mais pas à VCDS ?

:unsure:
 
Ben avec VCDS, on ne peut pas faire de mise à jour de firmware...

Pour faire les mises à jours de firmware il faut utiliser ODIS ou (je ne connais pas VCP).
 
Bon ben je vais devoir me procurer ODIS alors ... c'est l'occasion, ça faisait longtemps que je me demandais si je ne devrais pas l'essayer ;)

Mais apres comment on récupére les fichiers des firmware ?
 
- « ».

Au début du Tuto, je cite :

/!\Attention cette procédure est risquée et peut endommager le calculateur sans espoir de pouvoir le récupérer dans certains cas
Je ne pourrai être tenu responsable de quelques dommages que ce soit sur votre véhicule.
Cette manipulation est donc à vos risques et périls. /!\

Publicité

Les membres ne voient pas cette publicité.
 

Membres en train de lire

Publicité

Publicité

Les membres ne voient pas cette publicité.
Retour
Haut Bas