Bienvenu dans notre communauté !

Soit le bienvenu sur notre forum d'entre-aide mécanique spécialisé dans les véhicules du groupe VW. N'hésite pas à t'inscrire pour bénéficier d'un accès libre et sans limites à la base de connaissance que représente ce forum, ainsi qu'au savoir et conseils de ses membres. Nous voulons notre communauté simple et sans fioritures. À bientôt.

S'incrire maintenant

Publicité

Les membres ne voient pas cette publicité.

lionelcorbie80

Modérateur
Membre du Staff
Inscrit
30/11/19
messages
3 768
Localisation
Corbie -80-
Marque
Audi
Modèle
A4
Date
12/10/12
Cylindrée
2
Km
135000
Type
Diesel
Code moteur
CJCB
Code boite
NSX
VIN
WAUZZZ8K9DA080709
VCDS
VCDS
Bonjour, un soucis, je reçois ce jour plusieurs centaines de fois (274 exactement) le même courriel, émanant de @BigBob qui répond à un autre utilisateur du forum, j'ai désactivé la notification par mail de mon profil mais toujours la même chose, le soucis est intervenu aujourd'hui, rien pour hier !!!!
 

Publicité

Peux-tu regarder dans le détail des entêtes si tu as un ID différent ?

Exemple :

Received: by vag-technique.fr (Postfix, from userid 1002) id 17D406D5772; Fri, 11 Sep 2020 14:22:41 +0200 (CEST)
 
Dernière édition:
En effet l'id est différent pour exemple:

Received: from www.vag-technique.fr (localhost [127.0.0.1])
by vag-technique.fr (Postfix) with ESMTP id B23156C802A

Received: from localhost (localhost [127.0.0.1])
by vag-technique.fr (Postfix) with ESMTP id 782646D2B27
 
C'est dingue, ça a merdé je sais pas comment...

Et on est pas rendu :

[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
jeu. sept. 10 16:57:52 CEST 2020
active 20000
bounce 0
corrupt 0
defer 284520
deferred 284519
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
jeu. sept. 10 18:23:39 CEST 2020
active 20000
bounce 0
corrupt 0
defer 279124
deferred 279124
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
jeu. sept. 10 23:27:16 CEST 2020
active 20000
bounce 0
corrupt 0
defer 259712
deferred 259708
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
ven. sept. 11 08:04:23 CEST 2020
active 20000
bounce 0
corrupt 0
defer 225734
deferred 225732
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
ven. sept. 11 14:40:06 CEST 2020
active 20000
bounce 0
corrupt 0
defer 197778
deferred 197778
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
ven. sept. 11 18:42:58 CEST 2020
active 20000
bounce 0
corrupt 0
defer 180539
deferred 180537
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique deferred]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
ven. sept. 11 21:33:43 CEST 2020
active 20000
bounce 0
corrupt 0
defer 169374
deferred 169374
flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]#

On va finir par en voir le bout tout de même...
 
Bon, je viens de faire une petite session de tuning sur le serveur pour les domaines à problèmes :

wanadoo.com
wanadoo.fr
orange.com
orange.fr
nordnet.fr
yopmail.com
laposte.net
free.fr
alice.fr
ymail.com
rocketmail.com

We will see...
 
Salut sauf que moi c'est bouygues !!!
 
Bonjour,

Pour ma part : entre le 10/09 à 13h56 et le12/09 à 01h49, j'ai reçu 786 notifications du message de @BigBob ! 😂😂
(Je vous rassure : je ne suis pas maso, c'est Outlook qui a compté pour moi...)
Tous ces messages semblent être la répétition d'un seul message daté du 06/09 à 2357.

Par contre, (si je déchiffre correctement les en-têtes !!! ) ils n'ont été soumis au serveur SMTP que plus tard :
- le 07/09 à 1324 pour le premier, reçu le 10
- le 08/09 à 2209 pour le dernier, reçu le 12

Je suis abonné Free.
@BigBob : veux-tu des échantillons de ces messages, si tu peux tirer quelque chose de l'en-tête ? (je les ai momentanément gardés dans un dossier)


" deferred 169374 " : c'est le nombre de courriels que le facteur avait encore dans sa besace à l'instant T ? Boudu le pauvre ! 😇

Ca faisait un bon bout de temps que je ne recevais plus de notifications, mais peut-être n'y avait-il rien de nouveau sur les sujets pour lesquels j'ai un suivi.
En dehors de cette avalanche, je n'avais rien reçu entre le 17/08 (Polov16v190) et le 11/09 (Venuzplaneta).

A noter : le msg de Venuzplaneta a été posté le 08/09 à 1043, et je ne l'ai reçu que le 11/09 à 1919.
Ceci dit, vu la file d'attente...

Le bonjour de Toulouse, 21.2°C
 
Bonjour,

Pour ma part : entre le 10/09 à 13h56 et le12/09 à 01h49, j'ai reçu 786 notifications du message de @BigBob ! 😂😂
(Je vous rassure : je ne suis pas maso, c'est Outlook qui a compté pour moi...)
Tous ces messages semblent être la répétition d'un seul message daté du 06/09 à 2357.

Par contre, (si je déchiffre correctement les en-têtes !!! ) ils n'ont été soumis au serveur SMTP que plus tard :
- le 07/09 à 1324 pour le premier, reçu le 10
- le 08/09 à 2209 pour le dernier, reçu le 12

Je suis abonné Free.
@BigBob : veux-tu des échantillons de ces messages, si tu peux tirer quelque chose de l'en-tête ? (je les ai momentanément gardés dans un dossier)


" deferred 169374 " : c'est le nombre de courriels que le facteur avait encore dans sa besace à l'instant T ? Boudu le pauvre ! 😇

Ca faisait un bon bout de temps que je ne recevais plus de notifications, mais peut-être n'y avait-il rien de nouveau sur les sujets pour lesquels j'ai un suivi.
En dehors de cette avalanche, je n'avais rien reçu entre le 17/08 (Polov16v190) et le 11/09 (Venuzplaneta).

A noter : le msg de Venuzplaneta a été posté le 08/09 à 1043, et je ne l'ai reçu que le 11/09 à 1919.
Ceci dit, vu la file d'attente...

Le bonjour de Toulouse, 21.2°C

@Enric,

Normalement, j'ai fais les modifications « postfix » sur les domaines à problèmes (regarde mon message #5 au dessus...), « Free » en faisait parti, je surveille au cas où ce genre de merdouille se manifeste de nouveau.

" deferred 169374 " : c'est le nombre de courriels que le facteur avait encore dans sa besace à l'instant T ? Boudu le pauvre ! 😇


- « deferred 169374 », ce sont les messages qui se trouvent dans la queue « différée » parce qu'un problème d'envoi a eu lieu.
- Par contre je cherche une manière intelligente de résoudre le problème sans que j'ai besoin de faire des purges manuellement en aillant à surveiller l'état du bouzin (j'ai déjà une petite idée...).

Merci pour les informations (y)(y)(y).
 
Dernière édition:
Bonsoir,

@BigBob : pour info, je n'ai pas reçu de notification courriel pour ton message (je suis venu voir sur le site et -je m'y attendais un peu- , j'avais 1 notification par la cloche dans le bandeau).
Peut-être vais-je recevoir une bordée de notifications dans 3 ou 4 jours ? Mais si c'est le cas, tu devrais voir la file grossir dès à présent...

Question : ce sujet est-il le seul à avoir ce problème de diffusion des notifications ?
On pourrait le croire, puisqu'au milieu de cette logorrhée de notifications, j'ai reçu UNE notification pour un post de Venuzplaneta ( https://www.vag-technique.fr/thread...dows-10-x64-machine-virtuelle.21/unread?new=1 ), mais on ne peut pas se baser sur une seule occurrence pour tirer cette conclusion.

Pour ma culture personnelle, (mais sans te prendre la tête à me faire un cours ! ) peux-tu m'expliquer ce que sont ces modifs postfix, et (si à ce stade tu peux le voir) pourquoi un problème d'acheminement vers un domaine peut entraîner un tel nombre de réitérations de tentatives d'envoi du même message ?

(et si tu ne peux pas me dire pour le moment ou n'as pas envie de te lancer là dedans, je ne t'en tiendrai pas rigueur ! ;) )

Bona nueit !
Enric
 
Complément pour @BigBob
En me promenant dans les forums, j'ai trouvé la réponse à ma dernière question dans tes échanges avec Franck7319 ( https://www.vag-technique.fr/threads/re-bonjour.1472/ ) ...

Par contre, petite info : dans le cadre d'une asso, je gère les listes de diffusion, et nous avons de temps en temps des pb de msg non acheminés, car refusés pour spam par certains FAI comme... orange et consorts.
A priori, cela vient de ce que OVH (notre hébergeur) nous loue un serveur mutualisé (nous sommes pauvres...) et que nous partageons des adresses IP avec d'autres, qui eux font du spam. Du coup, même si les adresses tournent nous nous retrouvons avec des adresses d'expédition qui de temps en temps sont en liste noire pour certains FAI.
 
Alors il y avait 20000 messages qui étaient en attente dans la file « active », quand je me suis penché sur la problématique :

[root@vag-technique log]# date && for q in active bounce corrupt defer deferred flush hold incoming maildrop pid private public saved trace ; do count=$(find /var/spool/postfix/$q ! -type d -print | wc -l) ; echo $q $count ; done
jeu. sept. 10 16:57:52 CEST 2020
active 20000
bounce 0
corrupt 0
defer 284520
deferred 284519

flush 0
hold 0
incoming 0
maildrop 0
pid 16
private 23
public 5
saved 0
trace 0
[root@vag-technique log]#


À priori, le 06/09/2020 à 03:21:28, le daemon « amavis » a planté, daemon chargé de passer les mails à « clamav » (antivirus) et spamassassin (antispam) :

[root@vag-technique ~]# zgrep 'postfix/lmtp.*: connect to 127\.0\.0\.1\[127\.0\.0\.1]:10024: Connection refused' /var/log/maillog-20200913.gz | sed 5q
Sep 6 03:21:28 vag-technique postfix/lmtp[3683841]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 6 03:21:28 vag-technique postfix/lmtp[3683841]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 6 03:21:28 vag-technique postfix/lmtp[3683842]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 6 03:21:28 vag-technique postfix/lmtp[3683841]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 6 03:26:28 vag-technique postfix/lmtp[3683918]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
[root@vag-technique ~]#
lsof -ni | grep ":10024"
/usr/sbin 2173354 amavis 8u IPv4 101159351 0t0 TCP 127.0.0.1:10024 (LISTEN)
/usr/sbin 2173354 amavis 9u IPv6 101159352 0t0 TCP [::1]:10024 (LISTEN)
/usr/sbin 3094705 amavis 8u IPv4 101159351 0t0 TCP 127.0.0.1:10024 (LISTEN)
/usr/sbin 3094705 amavis 9u IPv6 101159352 0t0 TCP [::1]:10024 (LISTEN)
/usr/sbin 3094794 amavis 8u IPv4 101159351 0t0 TCP 127.0.0.1:10024 (LISTEN)
/usr/sbin 3094794 amavis 9u IPv6 101159352 0t0 TCP [::1]:10024 (LISTEN)
[root@vag-technique ~]#


Dans la commande « lsof » du dessus, le daemon « amavis » tourne correctement (commande effectuée aujourd'hui où tout est en ordre...), c'est juste pour montrer ce qui fonctionnait pas avec le message d'erreur de connexion dans la log au dessus).

Quand j'ai relancé « amavis » le 10, du coup tous les mails en file active ont été traités et envoyés dans la foulée.

Ça a relâché la purée d'un coup, pendant ce temps je cherchais à faire le tri dans les mails à supprimer et ceux à garder dans les files d'attentes...

Par contre, je ne m'explique toujours pas avec certitude le fait que les mêmes mails aient été dupliqués plusieurs fois lorsque « amavis » a planté...

Également, lorsque les vannes se sont ouvertes, les mails ont été envoyés très rapidement sur les multiples domaines des adresses mails de nos membres.

J'ai donc remarqué en regardant en live les log, les message pas du tout causant :

Mail rejected. ofr_506 [506] (in reply to end of DATA command))


et celui-ci (un peu plus causant pour le coup mais je ne savais pas comment régler le problème...) :

status=deferred (delivery temporarily suspended: host smtp-in.orange.fr[80.12.242.148] refused to talk to me: 421 mwinf5c29 ME Trop de connexions, veuillez verifier votre configuration. Too many connections, slow down. OFR004_104 [104]


Ce qui m'a amené sur ces sujets « », problème de mail considéré comme « indésirable » par orange, j'ai donc supprimé les mails correspondants.

et

« », et la solution que j'ai mis en œuvre sur le serveur...
 
Dernière édition:
Salut @BigBob , bien que mes notifications via emails soient correctement cochés, je ne reçois plus de notifications du site, une réparation à prévoir !!!!
 
Salut @BigBob , bien que mes notifications via emails soient correctement cochés, je ne reçois plus de notifications du site, une réparation à prévoir !!!!


J'ai peur que ce soit au niveau de l'administration du forum par lui-même, et pas un problème d'envois de mails.

J'ai demandé à @slinouille de me donner l'accès à l'interface d'administration pour jeter un œil, mais pour l'instant, il répond pas...
 

Publicité

Les membres ne voient pas cette publicité.
@lionelcorbie80 je te vois passer dans les logs :

Sep 14 12:02:58 id : B1BF06C00F6 -> status=sent
Sep 14 12:03:00 id: AABB16C0124 -> status=sent
Sep 14 12:03:00 id: 177CE6C00FC -> status=sent

Est-tu certain que tu ne reçois pas de mails ?

PS: J'ai essayé de te parler en chat privé, mais je pense que tu n'as pas vu la notification passer...
 
Salut @BigBob, oui en effet je ne recois pas les notifications, bien que mes option soient ok et que mon filtre de courriel soit opérationnel, je ne les recois pas du tout !!!!
 
Bonsoir,
Idem pour moi : 3 notifications sur le site dont celle de ce fil de discussion, mais aucune par courriel.

Merci pour les infos, même si à ce stade je ne peux pas les exploiter : notre site web est indépendant de nos listes de diffusion, qui sont techniquement gérées par OVH.
Je n'ai accès qu'à la gestion des listes : création, type de modération, modérateurs, abonnés.
aucun accès technique... :(

Enric
 
Saut, la notification par courriels est revenue, pour moi toujours est il !!!
 
Bonjour
Idem pour moi.

Publicité

Les membres ne voient pas cette publicité.
 

Membres en train de lire

Publicité

Publicité

Les membres ne voient pas cette publicité.
Retour
Haut Bas